Whenever you store a value that has a unit in a variable, config option or CLI switch, include the unit in the name. So:
maxRequestSize
=>maxRequestSizeBytes
elapsedTime
=>elapsedSeconds
cacheSize
=>cacheSizeMB
chargingTime
=>chargingTimeHours
fileSizeLimit
=>fileSizeLimitGB
temperatureThreshold
=>temperatureThresholdCelsius
diskSpace
=>diskSpaceTerabytes
flightAltitude
=>flightAltitudeFeet
monitorRefreshRate
=>monitorRefreshRateHz
serverResponseTimeout
=>serverResponseTimeoutMs
connectionSpeed
=>connectionSpeedMbps
EDIT: I know it’s better to use types to represent units. Please don’t write yet another comment about it. You can find my response to that point here: https://programming.dev/comment/219329
Those are just types. You shouldn’t write types in the names. It’s called Hungarian Notation, but it’s just redundant. If you need to check the type of a variable, hover over it and your IDE should tell you that
temperatureThreshold
is typeDegreesCelsius
. No need to add extra cruft. There’s also a question of how specific everything needs to be.This is especially problematic if you later refactor things. If you change units, then you have to rename every variable.
Plus, variables shouldn’t really be tied to a specific unit. If you need to display in Fahrenheit, you ideally just pass
temperatureThreshold
and it converts types as needed. ATemperature
type that that hasdegreesF()
anddegreesC()
functions is even cleaner. Units should just be private to the type’s struct.I absolutely agree. But:
- sometimes you need to modify existing code and you can’t add the types necessary without a giant refactoring
- you can’t express units with types in:
- JSON/YAML object keys
- XML tag or attribute names
- environment variable names
- CLI switch names
- database column names
- HTTP query parameters
- programming languages without a strong type system
Obviously as a Hungarian I have a soft spot for Hungarian notation :) But in these cases I think it’s necessary.
Not sure what languages you commonly work with, but in good modern languages you can simply declare “feet” as an alias of integer (or double?), and no refactoring would be required.
And any good toolchain to parse / generate JSON/etc can absolutely get the types right.
There are plenty of times where the type is just something generic like an integer and making a wrapper type is not worth the effort and this is a useful approach.
In languages with static and convenient type systems, I try to instead encode units as types. With clever C++ templating, you can even get implicit conversions (e.g. second -> hour) and compound types (e.g. meter and second types also generate m/s, m/s^2 and so on).
IIRC F# even has built-in support for units.
A good example is Go’s time package. You’d normally express durations like
5 * time.Second
and the result is atime.Duration
. Under the hood, it’s just an int64 nanoseconds, but you’d never use it as a plain nanoseconds. You’d instead use it liked.Seconds()
to get whichever unit you desire.
deleted by creator
That seems akin to commenting. The problem with this approach is that text is not code. It’s very easy to forget to change text. In that case it becomes the worst of both worlds, you have a variable name that actually misleads you.
Much safer than this is to encode this kind of information into the code itself in such a way the program won’t compile of the types are incorrect.
I understand what you mean, and I even agree with it, but just to be a little pedantic, variable names are code, or at least they are more code than comments or docs.
But yes, encoding units into the type system is a much better solution. It doesn’t work however for config options, environment variables or CLI switches.
fileSizeLimitGB
Surely its fileSizeLimitGiB
/s
Looks like Hungarian Notation
Related: Making Wrong Code Look Wrong
TL;DR: there is good and bad Hungarian notation. Encoding types (like string or int) in variable names is bad. Encoding information that cannot be expressed in the type system is good. (Though with the development of type systems, more and more of those concepts can be moved into the types, keeping variable names clean.)
But as a Hungarian, I’m obviously a little biased :)
It’s so annoying when you have to figure out what unit a variable is describing :(
But what if the FileSize can be „1G“, „1024M“, 518K“, etc.?
Documentation itself is much more important and modern IDEs and Editors will show you what to type in :)
In that case I would call the variable
fileSizeWithUnit
and also document what the possible units are. I wouldn’t say that documentation is categorically more important than good naming. Both are different aspects of good software development.Then use bytes
Variables, meh. As long as the code is clear, I don’t mind too much about naming. For config options? Absolutely.
I disagree. Every time I see
duration: Long
in code I want to find whoever wrote that and bash them on the head because what the fact this Long is? If unit is not immediately obvious in some way in current context (not necessarily as variable name), your code is not clear, period.
The better fix is to try to use types that represent those units or data types (e.g. duration instead of ms). Makes it harder to accidentally use the wrong units and documents the code / intent better.